xcrun导致的pod更新失败

系统升级到最新的sierra后,执行pod update 失败:

zcj-macair:qinmi alex$ pod update
-bash: /usr/local/bin/pod: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby: bad interpreter: No such file or directory
zcj-macair:qinmi alex$ brew install ryby
Updating Homebrew...
==> Using the sandbox
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
Error: git cannot be built with any available compilers.
Install GNU's GCC
  brew install gcc

Error: Git must be installed and in your PATH!
Error: No available formula with the name "ryby" 
==> Searching for similarly named formulae...
Error: No similarly named formulae found.
==> Searching taps...
Error: No formulae found in taps.

按照提示安装对应的程序时,进一步提示错误,发现是xcrun错误。

更新xcrun环境:xcode-select –install
更新ruby:brew install ruby
更新pod:gem install cocoapods

发表评论

电子邮件地址不会被公开。 必填项已用*标注